List View Filter shows only "all items"

Oct 2, 2011 at 11:29 AM

Hi,

I was wondering if I understand this solution wrong, or something is not working as it should :) After sucessfully installing the solution I created a new column and could successfully enable the lookup field. Also the query filter is working as at should. Anyhow I was expecting to specify the Column to show in the select box in the Apply List View Filter, although there is only one one option "All Items" available.

So my question is, how can I choose which column(s) to be shown/sepecify the List view filter?!

Or did I get something from?!

Kind regards

Michael

Nov 6, 2011 at 10:11 AM

I have exactly the same issue.   Do you already have an answer?

Nov 14, 2011 at 1:38 AM

It's not a List View Filter. It's a filter for the Lookup field.

The reason you see AllItems is because it's the only view you have on the source list.

Let's say I have a List called Days of the Week with a list of all days. I want to use this list as a lookup but only retrieve weekdays.

I have two options:

1. Create a view and filter out WHERE = Saturday and Sunday. Then select this view in the Lookup column settings.

2. Use the CAML query option and supply the relevant query.

<WHERE>

  <AND>

    <AND>

If you don't know CAML there are tools out there that can generate it for you.