Filtered Lookup column doesn't show any value

Aug 30, 2013 at 6:52 AM
Hi!

I have been working with the Filtered Lookup for a couple of months now and everything worked fine until now.

I created a custom list with a filtered lookup column, which refers to a list "Branch" on another site. I made the column mandatory and started creating test items in the list. Mostly this worked, but one value in the lookup field causes an error (there may be more faulty values, i haven't tested more yet). I can select the value but when I click Save the error "Branch is required" appears. I changed the column settings to "optional", which allowed for saving the list item. When I now look at the list, the lookup column of the new item is empty, even though I selected a value in the NewItem form.
I already tried deleting the column and creating it again, but the problem keeps occurring. I also had a look at the corresponding item in the "Branches" list, but it seems to be OK.

Can anyone help on this, please?

Thank you in advance! Katrin