Look up fields must be filled

Apr 8, 2009 at 8:26 AM
Hi,

I have a problem with the filtered lookup field.
I am using the look up field to look up a column in a list. Not all of the items have a value in the column I am looking up too.
What happens (when not all of the columns are filled) is that the filtered lookup field does not work at all. Is this behavior normal? 

Coordinator
Apr 9, 2009 at 4:31 PM
No, it's not a normal or expected behaviour.

Are you using "Query Filter" or "List View Filter"?

This issue is often associated with wrongly formed query filters. The best steps to resolving issues like this one are:

  1. For the purpose of this description, your source list is called MySourceList and your target list is called MyTargetList; typically (and also for the purpose of this description) these lists are different. Your source column in MySourceList is called MySourceColumn; this is the column whose values will be used in MyTargetList.
  2. Create a view in MySourceList (e.g. MySourceView)
  3. Verify that the view displays exactly what is expected and make sure the correct values are displaed in MySourceColumn.
  4. If all is fine and you are happy with the result, go to step 5.
  5. Open MyTargetList and add a new Filtered Lookup field (e.g. MyFilteredLookup).
  6. Set the properties of MyFilteredLookup to point to the MySourceList.
  7. Set query option property of MyFilteredLookup to "Use List View Query".
  8. Set the value of the dropdown box to MySourceView.
  9. You should see exactly the same values in MyFilteredlookup as would appear in MySourceColumn when you verified MySourceView in step 3 above.
  10. If all is well and you want to use "Query filter" option instead, you can extract the query from MySourceView and use that.
Regards,

Raphael
Apr 10, 2009 at 1:57 PM

I followed your steps and it only works correct if all the rows (in the view) have data in the column. What a way is to overcome this problem is to make a view that does not display the rows with empty columns. The downside of this is that there is an extra view which will not be uses by end users. Something they will have to live with.

Thanks for the fast response.

Coordinator
Apr 12, 2009 at 12:27 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.